<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">

<title>Album Review: Childish Gambino&#039;s 3.15.20 - SUU News</title>
<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Open+Sans:r,i,b,bi:latin,latin-ext"]},"typekit":{"id":"ngn8fuj"}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://suunews.net/wp-content/mu-plugins/wpcomsh/vendor/automattic/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css"></style>

<!-- This site is optimized with the Yoast SEO plugin v13.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="American rapper Daniel Glover, known as Childish Gambino dropped his fourth album. Reporter Alex Greenwell provides his opinion of the album."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Album Review: Childish Gambino&#039;s 3.15.20 - SUU News" />
<meta property="og:description" content="American rapper Daniel Glover, known as Childish Gambino dropped his fourth album. Reporter Alex Greenwell provides his opinion of the album." />
<meta property="og:url" content="https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/" />
<meta property="og:site_name" content="SUU News" />
<meta property="article:publisher" content="https://facebook.com/suunews/" />
<meta property="article:tag" content="campus news" />
<meta property="article:tag" content="Childish Gambino" />
<meta property="article:tag" content="college news" />
<meta property="article:tag" content="music" />
<meta property="article:tag" content="southern utah" />
<meta property="article:tag" content="Southern Utah News" />
<meta property="article:tag" content="Southern Utah Thunderbirds" />
<meta property="article:tag" content="Southern Utah University" />
<meta property="article:tag" content="Southern Utah University Thunderbirds" />
<meta property="article:tag" content="suu" />
<meta property="article:tag" content="SUU News" />
<meta property="article:tag" content="SUU Thunderbirds" />
<meta property="article:tag" content="T-Birds" />
<meta property="article:tag" content="tbirdnation" />
<meta property="article:tag" content="Thunderbirds" />
<meta property="article:section" content="Accent" />
<meta property="article:published_time" content="2020-03-30T20:24:09+00:00" />
<meta property="article:modified_time" content="2020-03-30T20:24:58+00:00" />
<meta property="og:updated_time" content="2020-03-30T20:24:58+00:00" />
<meta property="og:image" content="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=920%2C655&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=920%2C655&#038;ssl=1" />
<meta property="og:image:width" content="920" />
<meta property="og:image:height" content="655" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="American rapper Daniel Glover, known as Childish Gambino dropped his fourth album. Reporter Alex Greenwell provides his opinion of the album." />
<meta name="twitter:title" content="Album Review: Childish Gambino&#039;s 3.15.20 - SUU News" />
<meta name="twitter:site" content="@SUUNews" />
<meta name="twitter:image" content="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=920%2C655&#038;ssl=1" />
<meta name="twitter:creator" content="@SUUNews" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://suunews.net/#organization","name":"SUU News","url":"https://suunews.net/","sameAs":["https://facebook.com/suunews/","https://www.instagram.com/suu_news/","https://www.youtube.com/channel/UCHK2pqjFwMEP_3yJRwgr8Dw","https://twitter.com/SUUNews"],"logo":{"@type":"ImageObject","@id":"https://suunews.net/#logo","inLanguage":"en-US","url":"https://i0.wp.com/suunews.net/wp-content/uploads/2017/09/birdhead512.png?fit=512%2C512&ssl=1","width":"512","height":"512","caption":"SUU News"},"image":{"@id":"https://suunews.net/#logo"}},{"@type":"WebSite","@id":"https://suunews.net/#website","url":"https://suunews.net/","name":"SUU News","inLanguage":"en-US","description":"Student Media | Southern Utah University","publisher":{"@id":"https://suunews.net/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://suunews.net/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=920%2C655&ssl=1","width":920,"height":655},{"@type":"WebPage","@id":"https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/#webpage","url":"https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/","name":"Album Review: Childish Gambino&#039;s 3.15.20 - SUU News","isPartOf":{"@id":"https://suunews.net/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/#primaryimage"},"datePublished":"2020-03-30T20:24:09+00:00","dateModified":"2020-03-30T20:24:58+00:00","description":"American rapper Daniel Glover, known as Childish Gambino dropped his fourth album. Reporter Alex Greenwell provides his opinion of the album.","potentialAction":[{"@type":"ReadAction","target":["https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/"]}]},{"@type":"Article","@id":"https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/#article","isPartOf":{"@id":"https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/#webpage"},"author":{"@id":"https://suunews.net/#/schema/person/c45e00f21e03490df381234c23687214"},"headline":"Album Review: Childish Gambino&#8217;s 3.15.20","datePublished":"2020-03-30T20:24:09+00:00","dateModified":"2020-03-30T20:24:58+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/#webpage"},"publisher":{"@id":"https://suunews.net/#organization"},"image":{"@id":"https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/#primaryimage"},"keywords":"campus news,Childish Gambino,college news,music,southern utah,Southern Utah News,Southern Utah Thunderbirds,Southern Utah University,Southern Utah University Thunderbirds,suu,SUU News,SUU Thunderbirds,T-Birds,tbirdnation,Thunderbirds","articleSection":"Accent","inLanguage":"en-US"},{"@type":["Person"],"@id":"https://suunews.net/#/schema/person/c45e00f21e03490df381234c23687214","name":"Elizabeth Armstrong","image":{"@type":"ImageObject","@id":"https://suunews.net/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/5f6e7dd0938fb0d1a64b12a87d68dab2?s=96&d=identicon&r=g","caption":"Elizabeth Armstrong"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SUU News &raquo; Feed" href="https://suunews.net/feed/" />
<!-- This site uses the Google Analytics by ExactMetrics plugin v6.0.2 - Using Analytics tracking - https://www.exactmetrics.com/ -->
<script type="text/javascript" data-cfasync="false">
	var em_version         = '6.0.2';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-107120425-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-107120425-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview', location.pathname + location.search + location.hash);
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>
<!-- / Google Analytics by ExactMetrics -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/suunews.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- suunews.net is managing ads with Advanced Ads – https://wpadvancedads.com/ --><script>
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
						</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://suunews.net/wp-content/plugins/gutenberg/build/block-library/style.css?ver=1573887143' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://suunews.net/wp-content/plugins/gutenberg/build/block-library/theme.css?ver=1573887143' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-event-countdown-css'  href='https://suunews.net/wp-content/plugins/full-site-editing/event-countdown-block/style.css?ver=1576877996' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-timeline-css'  href='https://suunews.net/wp-content/plugins/full-site-editing/jetpack-timeline/style.css?ver=1576877996' type='text/css' media='all' />
<link rel='stylesheet' id='blog-posts-block-view-css'  href='https://suunews.net/wp-content/plugins/full-site-editing/blog-posts-block/dist/view.css?ver=v1.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='posts-list-block-style-css'  href='https://suunews.net/wp-content/plugins/full-site-editing/posts-list-block/dist/posts-list-block.css?ver=1582931902' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://suunews.net/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='magazine_layout_css-css'  href='https://suunews.net/wp-content/plugins/issuu-magazine-display/css/imd_style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpcf-slick-css'  href='https://suunews.net/wp-content/plugins/wp-carousel-free/public/css/slick.min.css?ver=2.1.9' type='text/css' media='all' />
<link rel='stylesheet' id='wp-carousel-free-fontawesome-css'  href='https://suunews.net/wp-content/plugins/wp-carousel-free/public/css/font-awesome.min.css?ver=2.1.9' type='text/css' media='all' />
<link rel='stylesheet' id='wp-carousel-free-css'  href='https://suunews.net/wp-content/plugins/wp-carousel-free/public/css/wp-carousel-free-public.min.css?ver=2.1.9' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='hitmag-fonts-css'  href='https://fonts.googleapis.com/css?family=Ubuntu%3A400%2C500%2C700%7CLato%3A400%2C700%2C400italic%2C700italic%7COpen+Sans%3A400%2C400italic%2C700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://suunews.net/wp-content/themes/hitmag/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='hitmag-style-css'  href='https://suunews.net/wp-content/themes/hitmag/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-flexslider-css'  href='https://suunews.net/wp-content/themes/hitmag/css/flexslider.css?ver=5.3.2' type='text/css' media='screen' />
<link rel='stylesheet' id='jquery-magnific-popup-css'  href='https://suunews.net/wp-content/themes/hitmag/css/magnific-popup.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-global-styles-frontend-style-css'  href='https://suunews.net/wp-content/plugins/full-site-editing/global-styles/static/blank.css?ver=2003121439' type='text/css' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css' type='text/css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.3/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/out\\\/\",\"label\":\"Affiliate\"}]","home_url":"https:\/\/suunews.net","hash_tracking":"true"};
/* ]]> */
</script>
<script type='text/javascript' src='https://suunews.net/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js?ver=6.0.2'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://suunews.net/wp-content/themes/hitmag/js/html5shiv.min.js?ver=5.3.2'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://suunews.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://suunews.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://suunews.net/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p99vuU-3lV' />
<link rel="alternate" type="application/json+oembed" href="https://suunews.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsuunews.net%2F2020%2F03%2F30%2Falbum-review-childish-gambinos-3-15-20%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://suunews.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsuunews.net%2F2020%2F03%2F30%2Falbum-review-childish-gambinos-3-15-20%2F&#038;format=xml" />
<meta property="fb:app_id" content=""/>          <style>
          .has-post-thumbnail img.wp-post-image, 
          .attachment-twentyseventeen-featured-image.wp-post-image { display: none !important; }          
          </style>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>		<style type="text/css">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</style>
		<style type="text/css">

			.site-title a,
		.site-description {
			position: absolute;
			clip: rect(1px, 1px, 1px, 1px);
		}

	
	</style>
				<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="amphtml" href="https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/amp/"><link rel="icon" href="https://i0.wp.com/suunews.net/wp-content/uploads/2017/09/birdhead512.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/suunews.net/wp-content/uploads/2017/09/birdhead512.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/suunews.net/wp-content/uploads/2017/09/birdhead512.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/suunews.net/wp-content/uploads/2017/09/birdhead512.png?fit=270%2C270&#038;ssl=1" />
</head>

<body class="post-template-default single single-post postid-12891 single-format-standard wp-custom-logo group-blog th-right-sidebar">



<div id="page" class="site hitmag-wrapper">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	
	<header id="masthead" class="site-header" role="banner">

		
			
			<div class="hm-top-bar">
				<div class="hm-container">
					
					
					
					<div class="hm-social-menu"><div id="hm-menu-social" class="menu"><ul id="menu-social-items" class="menu-items"><li id="menu-item-11" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11"><a href="https://twitter.com/suunews"><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-12" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12"><a href="https://www.facebook.com/suunews"><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-289" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-289"><a href="https://www.instagram.com/suu_news/"><span class="screen-reader-text">Instagram</span></a></li>
</ul></div></div>
				</div><!-- .hm-container -->
			</div><!-- .hm-top-bar -->

		
		
		<div class="header-main-area ">
			<div class="hm-container">
			<div class="site-branding">
				<div class="site-branding-content">
					<div class="hm-logo">
						<a href="https://suunews.net/" class="custom-logo-link" rel="home"><img width="2136" height="407" src="https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/web_header-2.png?fit=2136%2C407&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="SUU News" data-attachment-id="101" data-permalink="https://suunews.net/web_header-2/" data-orig-file="https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/web_header-2.png?fit=2136%2C407&amp;ssl=1" data-orig-size="2136,407" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Web_Header-2" data-image-description="" data-medium-file="https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/web_header-2.png?fit=300%2C57&amp;ssl=1" data-large-file="https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/web_header-2.png?fit=735%2C140&amp;ssl=1" data-lazy-src="https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/web_header-2.png?fit=2136%2C407&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>					</div><!-- .hm-logo -->

					<div class="hm-site-title">
													<p class="site-title"><a href="https://suunews.net/" rel="home">SUU News</a></p>
													<p class="site-description">Student Media | Southern Utah University</p>
											</div><!-- .hm-site-title -->
				</div><!-- .site-branding-content -->
			</div><!-- .site-branding -->

			
						</div><!-- .hm-container -->
		</div><!-- .header-main-area -->

		
		<div class="hm-nav-container">
			<nav id="site-navigation" class="main-navigation" role="navigation">
				<div class="hm-container">
					<div class="menu-primary-container"><ul id="primary-menu" class="menu"><li id="menu-item-8" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8"><a href="/">Home</a></li>
<li id="menu-item-12593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12593"><a href="https://suunews.net/category/covid-19/">COVID-19</a></li>
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46"><a href="https://suunews.net/category/news/">News</a></li>
<li id="menu-item-49" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49"><a href="https://suunews.net/category/sports/">Sports</a></li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://suunews.net/category/outside/">Outdoors</a></li>
<li id="menu-item-44" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-44"><a href="https://suunews.net/category/accent/">Accent</a></li>
<li id="menu-item-45" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45"><a href="https://suunews.net/category/student-life/">Life</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47"><a href="https://suunews.net/category/opinion/">Opinion</a></li>
<li id="menu-item-6912" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6912"><a href="https://suunews.net/podcasts/">Podcasts</a>
<ul class="sub-menu">
	<li id="menu-item-6917" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6917"><a href="https://suunews.net/podcasts/a-date-with-sugar-spice/">A Date with Sugar &#038; Spice</a></li>
	<li id="menu-item-8657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8657"><a href="https://suunews.net/podcasts/amanda-and-a-man/">Reyce’s Rapport</a></li>
	<li id="menu-item-9136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9136"><a href="https://suunews.net/podcasts/phantamagoria/">Phantasmagoria</a></li>
	<li id="menu-item-6915" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6915"><a href="https://suunews.net/podcasts/thundercast-sports/">Thundercast with Connor Sanders</a></li>
</ul>
</li>
<li id="menu-item-51" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-51"><a href="https://suunews.net/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-232" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-232"><a href="https://suunews.net/about/submit-to-suunews/">Submit to SUUNews</a></li>
	<li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://suunews.net/about/the-university-journal-print-edition/">The University Journal Print Edition</a></li>
	<li id="menu-item-3161" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3161"><a href="https://suunews.net/about/advertisement/">Advertisement</a></li>
	<li id="menu-item-9980" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9980"><a href="https://suunews.net/about/our-staff/">Our Staff</a></li>
</ul>
</li>
</ul></div>					
											<div class="hm-search-button-icon"></div>
						<div class="hm-search-box-container">
							<div class="hm-search-box">
								<form role="search" method="get" class="search-form" action="https://suunews.net/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>							</div><!-- th-search-box -->
						</div><!-- .th-search-box-container -->
									</div><!-- .hm-container -->
			</nav><!-- #site-navigation -->
			<div class="hm-nwrap">
				<a href="#" class="navbutton" id="main-nav-button">Main Menu</a>
			</div>
			<div class="responsive-mainnav"></div>
		</div><!-- .hm-nav-container -->

		
	</header><!-- #masthead -->

	
	<div id="content" class="site-content">
		<div class="hm-container">
	
	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
<article id="post-12891" class="hitmag-single post-12891 post type-post status-publish format-standard has-post-thumbnail hentry category-accent tag-campus-news tag-childish-gambino tag-college-news tag-music tag-southern-utah tag-southern-utah-news tag-southern-utah-thunderbirds tag-southern-utah-university tag-southern-utah-university-thunderbirds tag-suu tag-suu-news tag-suu-thunderbirds tag-t-birds tag-tbirdnation tag-thunderbirds">

	
	<header class="entry-header">
		<div class="cat-links"><a href="https://suunews.net/category/accent/" rel="category tag">Accent</a></div><h1 class="entry-title">Album Review: Childish Gambino&#8217;s 3.15.20</h1>		<div class="entry-meta">
			<span class="posted-on"><a href="https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/" rel="bookmark"><time class="entry-date published" datetime="2020-03-30T14:24:09-06:00">March 30, 2020</time><time class="updated" datetime="2020-03-30T14:24:58-06:00">March 30, 2020</time></a></span><span class="meta-sep"> - </span><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://suunews.net/author/accentsuunews/">Elizabeth Armstrong</a></span></span>		</div><!-- .entry-meta -->
		
	</header><!-- .entry-header -->
	
	<a class="image-link" href="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=920%2C655&#038;ssl=1"><img width="735" height="400" src="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?resize=735%2C400&amp;ssl=1" class="attachment-hitmag-featured size-hitmag-featured wp-post-image jetpack-lazy-image" alt="" data-attachment-id="12893" data-permalink="https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/childish-gambino-press/" data-orig-file="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=920%2C655&amp;ssl=1" data-orig-size="920,655" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="childish-gambino-press" data-image-description="" data-medium-file="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=300%2C214&amp;ssl=1" data-large-file="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=735%2C523&amp;ssl=1" data-lazy-src="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?resize=735%2C400&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
	
	<div class="entry-content">
		<p><span style="font-weight: 400;">Some longtime fans of Childish Gambino might have been surprised by the heavily digital sound of his new album “3.15.20.” The song “0.00” begins the album with a note similar to a dial-tone before transitioning to the echoing, synthesized phrase of “We are, we are, we are.”</span></p>
<p><span style="font-weight: 400;">Despite this abstract beginning, the album regains the heavy, high pace driven momentum typically found in Gambino’s music with the second track, “Algorhythm.” With a discordant beat, the listener is thrown into the first synthesized verse from Gambino. This aggressive melody creates the mood of the rest of the album.</span></p>
<p><span style="font-weight: 400;"><img data-attachment-id="12893" data-permalink="https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/childish-gambino-press/" data-orig-file="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=920%2C655&amp;ssl=1" data-orig-size="920,655" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="childish-gambino-press" data-image-description data-medium-file="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=300%2C214&amp;ssl=1" data-large-file="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=735%2C523&amp;ssl=1" class="alignright size-medium wp-image-12893 jetpack-lazy-image" src="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?resize=300%2C214&#038;ssl=1" alt width="300" height="214" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?resize=300%2C214&amp;ssl=1 300w, https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?resize=768%2C547&amp;ssl=1 768w, https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?w=920&amp;ssl=1 920w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?resize=300%2C214&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="12893" data-permalink="https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/childish-gambino-press/" data-orig-file="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=920%2C655&amp;ssl=1" data-orig-size="920,655" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="childish-gambino-press" data-image-description="" data-medium-file="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=300%2C214&amp;ssl=1" data-large-file="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?fit=735%2C523&amp;ssl=1" class="alignright size-medium wp-image-12893" src="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?resize=300%2C214&#038;ssl=1" alt="" width="300" height="214" srcset="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?resize=300%2C214&amp;ssl=1 300w, https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?resize=768%2C547&amp;ssl=1 768w, https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/childish-gambino-press.jpg?w=920&amp;ssl=1 920w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript>“3.15.20” is a departure from Gambino’s previous albums but ultimately features all the skills and complexities that Gambino has developed throughout his career. The  storyline seems to be speaking to the listener throughout the album, with the transitions between tracks t almost undetectable due to a baseline electronic beat.</span></p>
<p><span style="font-weight: 400;">The album features 12 songs. 10 of those are titled as different numbers, with the exception of “Algorhythm” and “Time.” Whereas “Algorhythm” showcased chaos and aggressive beat placement, “Time” features a more harmonious melody with the introduction of an acoustic sound to accompany the basic electronic beat that was used to transition into the song. </span></p>
<p><span style="font-weight: 400;">“Time” also features Ariana Grande, her vocals contrasting and complimenting Gambino’s voice, with the track finishing with a choral background and ultimately ending on yet another dissonant, electronic beat, before being flung directly into a rap verse in “12.38.”</span></p>
<p><span style="font-weight: 400;">The remaining songs featured on the album maintain a general theme of electronic sounds, R&amp;B tones, and funk. Songs such as “19.20.” “32.22.” and the final track of the album “53.49” all display aggressive tones and vocals similar to previous tracks in Gambino’s discography such as “3005” and “Freaks and Geeks.” </span></p>
<p><span style="font-weight: 400;"><img data-attachment-id="12895" data-permalink="https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/gambino/" data-orig-file="https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?fit=225%2C225&amp;ssl=1" data-orig-size="225,225" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="gambino" data-image-description data-medium-file="https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?fit=225%2C225&amp;ssl=1" data-large-file="https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?fit=225%2C225&amp;ssl=1" class="size-full wp-image-12895 alignleft jetpack-lazy-image" src="https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?resize=225%2C225&#038;ssl=1" alt width="225" height="225" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?w=225&amp;ssl=1 225w, https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?resize=200%2C200&amp;ssl=1 200w" data-lazy-sizes="(max-width: 225px) 100vw, 225px" data-lazy-src="https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?resize=225%2C225&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="12895" data-permalink="https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/gambino/" data-orig-file="https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?fit=225%2C225&amp;ssl=1" data-orig-size="225,225" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="gambino" data-image-description="" data-medium-file="https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?fit=225%2C225&amp;ssl=1" data-large-file="https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?fit=225%2C225&amp;ssl=1" class="size-full wp-image-12895 alignleft" src="https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?resize=225%2C225&#038;ssl=1" alt="" width="225" height="225" srcset="https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?w=225&amp;ssl=1 225w, https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/suunews.net/wp-content/uploads/2020/03/gambino.jpg?resize=200%2C200&amp;ssl=1 200w" sizes="(max-width: 225px) 100vw, 225px" data-recalc-dims="1" /></noscript>“19.20.” “32.22.” and “53.49” all showcase this aggressive style while working with the instrumentals to create a cohesive and distinct tone throughout each track. This marriage between instrumentals and performance style sets this album apart from Gambino’s previous albums.</span></p>
<p><span style="font-weight: 400;">Gambino also includes more political commentary sprinkled throughout the album. There are lyrics conveying the state of black rights in America, particularly in “47.48” which has themes of the #BlackLivesMatter movement. This commentary is expected from an artist of Gambino’s caliber, particularly following the release of his track “This is America” in May 2018. </span></p>
<p><span style="font-weight: 400;">Along with “47.48” Gambino creates discussion of black culture in “35.31.” This song also includes a backwards monologue at the completion of the song that is later repeated in “39.28.” This monologue in “35.31” juxtaposes the rather joyous track, possibly explaining the reasoning behind the backmasking of the verse that is later found in the almost spoken-word, slam poetry track of “39.28.”</span></p>
<p><span style="font-weight: 400;">The album features a familiar track, previously titled “Feels Like Summer” that is retitled as “42.26.” This track was originally released in July 2018, with the only changes to the track being an introduction and transition that reflects the digitalized theme found throughout the album.</span></p>
<p><span style="font-weight: 400;">The final two tracks of the album showcase an emotional and celebratory melody, particularly in “47.48” which finishes off with a soundbite between Gambino and a child. This touching moment closes the album before re-igniting into the explosive finale of “53.49” that features energetic vocals, passionate harmonies and celebratory energy.</span></p>
<p><span style="font-weight: 400;">Ultimately, “3.15.20” sets itself apart from the rest of Gambino’s discography while showcasing his development in the music industry.</span></p>
<p>To listen to the album, click <a href="https://open.spotify.com/album/600ClrWRsAr7jZ0qjaBLHz">here</a>.</p>
<p><b>Story by Alex Greenwell</b><b><br />
</b><a href="mailto:news@suunews.net"><b>news@suunews.net</b></a><b><br />
Photos by: complex.com and genius.com</b></p>
<div id="wpdevar_comment_1" style="width:100%;text-align:left;">
		<span style="padding: 10px;font-size:15px;font-family:Times New Roman,Times,Serif,Georgia;color:#000000;">Facebook Comments</span>
		<div class="fb-comments" data-href="https://suunews.net/2020/03/30/album-review-childish-gambinos-3-15-20/" data-order-by="social" data-numposts="5" data-width="100%" style="display:block;"></div></div><style>#wpdevar_comment_1 span,#wpdevar_comment_1 iframe{width:100% !important;}</style>	</div><!-- .entry-content -->

	
	<footer class="entry-footer">
		<span class="hm-tags-links"><span class="hm-tagged">Tagged</span><a href="https://suunews.net/tag/campus-news/" rel="tag">campus news</a><a href="https://suunews.net/tag/childish-gambino/" rel="tag">Childish Gambino</a><a href="https://suunews.net/tag/college-news/" rel="tag">college news</a><a href="https://suunews.net/tag/music/" rel="tag">music</a><a href="https://suunews.net/tag/southern-utah/" rel="tag">southern utah</a><a href="https://suunews.net/tag/southern-utah-news/" rel="tag">Southern Utah News</a><a href="https://suunews.net/tag/southern-utah-thunderbirds/" rel="tag">Southern Utah Thunderbirds</a><a href="https://suunews.net/tag/southern-utah-university/" rel="tag">Southern Utah University</a><a href="https://suunews.net/tag/southern-utah-university-thunderbirds/" rel="tag">Southern Utah University Thunderbirds</a><a href="https://suunews.net/tag/suu/" rel="tag">suu</a><a href="https://suunews.net/tag/suu-news/" rel="tag">SUU News</a><a href="https://suunews.net/tag/suu-thunderbirds/" rel="tag">SUU Thunderbirds</a><a href="https://suunews.net/tag/t-birds/" rel="tag">T-Birds</a><a href="https://suunews.net/tag/tbirdnation/" rel="tag">tbirdnation</a><a href="https://suunews.net/tag/thunderbirds/" rel="tag">Thunderbirds</a></span>	</footer><!-- .entry-footer -->

	
</article><!-- #post-## -->
    <div class="hm-related-posts">
    
    <div class="wt-container">
        <h4 class="widget-title">Related Posts</h4>
    </div>

    <div class="hmrp-container">

        
                <div class="hm-rel-post">
                    <a href="https://suunews.net/2020/03/30/bachelor-of-fine-arts-senior-exhibition-at-suma/" rel="bookmark" title="Bachelor of Fine Arts Senior Exhibition at SUMA">
                        <img width="348" height="200" src="https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/03-2020-bfa-show.jpg?resize=348%2C200&amp;ssl=1" class="attachment-hitmag-grid size-hitmag-grid wp-post-image jetpack-lazy-image" alt="" data-attachment-id="12889" data-permalink="https://suunews.net/2020/03/30/bachelor-of-fine-arts-senior-exhibition-at-suma/03-2020-bfa-show/" data-orig-file="https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/03-2020-bfa-show.jpg?fit=400%2C200&amp;ssl=1" data-orig-size="400,200" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="03-2020-bfa-show" data-image-description="" data-medium-file="https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/03-2020-bfa-show.jpg?fit=300%2C150&amp;ssl=1" data-large-file="https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/03-2020-bfa-show.jpg?fit=400%2C200&amp;ssl=1" data-lazy-src="https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/03-2020-bfa-show.jpg?resize=348%2C200&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />                    </a>
                    <h3 class="post-title">
                        <a href="https://suunews.net/2020/03/30/bachelor-of-fine-arts-senior-exhibition-at-suma/" rel="bookmark" title="Bachelor of Fine Arts Senior Exhibition at SUMA">
                            Bachelor of Fine Arts Senior Exhibition at SUMA                        </a>
                    </h3>
                    <p class="hms-meta"><time class="entry-date published" datetime="2020-03-30T14:02:36-06:00">March 30, 2020</time><time class="updated" datetime="2020-03-30T15:09:31-06:00">March 30, 2020</time></p>
                </div>
            
            
                <div class="hm-rel-post">
                    <a href="https://suunews.net/2020/03/27/utah-shakespeare-festival-2020-preview/" rel="bookmark" title="Utah Shakespeare Festival 2020 Preview">
                        <img width="348" height="215" src="https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/DGreenshowB-7144.jpg?resize=348%2C215&amp;ssl=1" class="attachment-hitmag-grid size-hitmag-grid wp-post-image jetpack-lazy-image" alt="" data-attachment-id="12733" data-permalink="https://suunews.net/2020/03/27/utah-shakespeare-festival-2020-preview/dgreenshowb-7144/" data-orig-file="https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/DGreenshowB-7144.jpg?fit=2315%2C1544&amp;ssl=1" data-orig-size="2315,1544" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;10&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D5&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1530041892&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;240&quot;,&quot;iso&quot;:&quot;250&quot;,&quot;shutter_speed&quot;:&quot;0.0025&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DGreenshowB-7144" data-image-description="" data-medium-file="https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/DGreenshowB-7144.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/DGreenshowB-7144.jpg?fit=735%2C490&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/DGreenshowB-7144.jpg?resize=348%2C215&amp;ssl=1 348w, https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/DGreenshowB-7144.jpg?zoom=2&amp;resize=348%2C215&amp;ssl=1 696w, https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/DGreenshowB-7144.jpg?zoom=3&amp;resize=348%2C215&amp;ssl=1 1044w" data-lazy-sizes="(max-width: 348px) 100vw, 348px" data-lazy-src="https://i0.wp.com/suunews.net/wp-content/uploads/2020/03/DGreenshowB-7144.jpg?resize=348%2C215&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />                    </a>
                    <h3 class="post-title">
                        <a href="https://suunews.net/2020/03/27/utah-shakespeare-festival-2020-preview/" rel="bookmark" title="Utah Shakespeare Festival 2020 Preview">
                            Utah Shakespeare Festival 2020 Preview                        </a>
                    </h3>
                    <p class="hms-meta"><time class="entry-date published updated" datetime="2020-03-27T13:07:12-06:00">March 27, 2020</time></p>
                </div>
            
            
                <div class="hm-rel-post">
                    <a href="https://suunews.net/2020/03/26/honoring-playwright-terrence-mcnally/" rel="bookmark" title="Honoring Playwright Terrence McNally">
                        <img width="224" height="215" src="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/terrence-mcnally.jpg?resize=224%2C215&amp;ssl=1" class="attachment-hitmag-grid size-hitmag-grid wp-post-image jetpack-lazy-image" alt="" data-attachment-id="12843" data-permalink="https://suunews.net/2020/03/26/honoring-playwright-terrence-mcnally/terrence-mcnally/" data-orig-file="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/terrence-mcnally.jpg?fit=224%2C225&amp;ssl=1" data-orig-size="224,225" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="terrence mcnally" data-image-description="" data-medium-file="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/terrence-mcnally.jpg?fit=224%2C225&amp;ssl=1" data-large-file="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/terrence-mcnally.jpg?fit=224%2C225&amp;ssl=1" data-lazy-src="https://i2.wp.com/suunews.net/wp-content/uploads/2020/03/terrence-mcnally.jpg?resize=224%2C215&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />                    </a>
                    <h3 class="post-title">
                        <a href="https://suunews.net/2020/03/26/honoring-playwright-terrence-mcnally/" rel="bookmark" title="Honoring Playwright Terrence McNally">
                            Honoring Playwright Terrence McNally                        </a>
                    </h3>
                    <p class="hms-meta"><time class="entry-date published updated" datetime="2020-03-26T13:23:09-06:00">March 26, 2020</time></p>
                </div>
            
            
    </div>
    </div>

    
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://suunews.net/2020/03/30/bachelor-of-fine-arts-senior-exhibition-at-suma/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous Article</span> <span class="post-title">Bachelor of Fine Arts Senior Exhibition at SUMA</span></a></div></div>
	</nav>
		</main><!-- #main -->
	</div><!-- #primary -->


<aside id="secondary" class="widget-area" role="complementary">

	
	<section id="media_video-3" class="widget widget_media_video"><h4 class="widget-title">SUU News TV</h4><style>.widget.widget_media_video iframe { margin: 0; }</style><div style="width:100%;" class="wp-video"><!--[if lt IE 9]><script>document.createElement('video');</script><![endif]-->
<video class="wp-video-shortcode" id="video-12891-1" loop="1" preload="metadata" controls="controls"><source type="video/youtube" src="https://www.youtube.com/watch?v=jK4iQp_vyMI&#038;fbclid=IwAR1-ahkUc7VZhd7lisDCpxCPSbTtSmNho1kdGmfL4h0Jg2nzAomGkyRwnmU&#038;_=1" /><a href="https://www.youtube.com/watch?v=jK4iQp_vyMI&#038;fbclid=IwAR1-ahkUc7VZhd7lisDCpxCPSbTtSmNho1kdGmfL4h0Jg2nzAomGkyRwnmU">https://www.youtube.com/watch?v=jK4iQp_vyMI&#038;fbclid=IwAR1-ahkUc7VZhd7lisDCpxCPSbTtSmNho1kdGmfL4h0Jg2nzAomGkyRwnmU</a></video></div></section><section id="custom_html-3" class="widget_text widget widget_custom_html"><h4 class="widget-title">Thunder 91.1 Live</h4><div class="textwidget custom-html-widget"><iframe allowfullscreen="allowfullscreen" height="75" src="https://cdnapisec.kaltura.com/p/1658411/sp/165841100/embedIframeJs/uiconf_id/34122032/partner_id/1658411?iframeembed=true&amp;playerId=kaltura_player_1500487274&amp;entry_id=0_fqswk5fh&amp;flashvars[streamerType]=auto" style="width: 100%; height: 75px;" width="100%"> <span content="Thunder 91 Live Stream" itemprop="name"></span> <span content="Audio from SUU radio station" itemprop="description"></span> <span content="0" itemprop="duration"></span> <span content="https://cfvod.kaltura.com/p/1658411/sp/165841100/thumbnail/entry_id/0_fqswk5fh/version/0" itemprop="thumbnail"></span> <span content="560" itemprop="width"></span> <span content="75" itemprop="height"></span> </iframe>
</div></section><section id="advads_ad_widget-4" class="widget suune-widget"><a href="https://www.clarklinford.com"><img width="2700" height="3450" src='https://i2.wp.com/suunews.net/wp-content/uploads/2019/04/ClarkLinford.jpg?fit=2700%2C3450&ssl=1' alt=''  /></a></section>
	
</aside><!-- #secondary -->	</div><!-- .hm-container -->
	</div><!-- #content -->

	
	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="hm-container">

			
			<div class="footer-widget-area">
				<div class="footer-sidebar" role="complementary">
					<aside id="archives-3" class="widget widget_archive"><h4 class="footer-widget-title">Archives</h4>		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://suunews.net/2020/03/'> March 2020 </option>
	<option value='https://suunews.net/2020/02/'> February 2020 </option>
	<option value='https://suunews.net/2020/01/'> January 2020 </option>
	<option value='https://suunews.net/2019/12/'> December 2019 </option>
	<option value='https://suunews.net/2019/11/'> November 2019 </option>
	<option value='https://suunews.net/2019/10/'> October 2019 </option>
	<option value='https://suunews.net/2019/09/'> September 2019 </option>
	<option value='https://suunews.net/2019/08/'> August 2019 </option>
	<option value='https://suunews.net/2019/07/'> July 2019 </option>
	<option value='https://suunews.net/2019/06/'> June 2019 </option>
	<option value='https://suunews.net/2019/05/'> May 2019 </option>
	<option value='https://suunews.net/2019/04/'> April 2019 </option>
	<option value='https://suunews.net/2019/03/'> March 2019 </option>
	<option value='https://suunews.net/2019/02/'> February 2019 </option>
	<option value='https://suunews.net/2019/01/'> January 2019 </option>
	<option value='https://suunews.net/2018/12/'> December 2018 </option>
	<option value='https://suunews.net/2018/11/'> November 2018 </option>
	<option value='https://suunews.net/2018/10/'> October 2018 </option>
	<option value='https://suunews.net/2018/09/'> September 2018 </option>
	<option value='https://suunews.net/2018/08/'> August 2018 </option>
	<option value='https://suunews.net/2018/07/'> July 2018 </option>
	<option value='https://suunews.net/2018/06/'> June 2018 </option>
	<option value='https://suunews.net/2018/05/'> May 2018 </option>
	<option value='https://suunews.net/2018/04/'> April 2018 </option>
	<option value='https://suunews.net/2018/03/'> March 2018 </option>
	<option value='https://suunews.net/2018/02/'> February 2018 </option>
	<option value='https://suunews.net/2018/01/'> January 2018 </option>
	<option value='https://suunews.net/2017/12/'> December 2017 </option>
	<option value='https://suunews.net/2017/11/'> November 2017 </option>
	<option value='https://suunews.net/2017/10/'> October 2017 </option>
	<option value='https://suunews.net/2017/09/'> September 2017 </option>
	<option value='https://suunews.net/2017/08/'> August 2017 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</aside>				</div><!-- .footer-sidebar -->
		
				<div class="footer-sidebar" role="complementary">
					<aside id="meta-5" class="widget widget_meta"><h4 class="footer-widget-title">Login</h4>			<ul>
			<li><a rel="nofollow" href="https://suunews.net/wp-login.php?action=register">Register</a></li>			<li><a rel="nofollow" href="https://suunews.net/wp-login.php">Log in</a></li>
			<li><a href="https://suunews.net/feed/">Entries feed</a></li>
			<li><a href="https://suunews.net/comments/feed/">Comments feed</a></li>
			<li><a href="https://wordpress.org/">WordPress.org</a></li>			</ul>
			</aside>				</div><!-- .footer-sidebar -->		

				<div class="footer-sidebar" role="complementary">
					<aside id="media_image-3" class="widget widget_media_image"><style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><img width="300" height="300" src="https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/Logo.png?fit=300%2C300&amp;ssl=1" class="image wp-image-292  attachment-medium size-medium jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-attachment-id="292" data-permalink="https://suunews.net/logo/" data-orig-file="https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/Logo.png?fit=2250%2C2250&amp;ssl=1" data-orig-size="2250,2250" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Logo" data-image-description="" data-medium-file="https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/Logo.png?fit=300%2C300&amp;ssl=1" data-large-file="https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/Logo.png?fit=735%2C735&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/Logo.png?w=2250&amp;ssl=1 2250w, https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/Logo.png?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/Logo.png?resize=300%2C300&amp;ssl=1 300w, https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/Logo.png?resize=1024%2C1024&amp;ssl=1 1024w, https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/Logo.png?w=1470&amp;ssl=1 1470w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i1.wp.com/suunews.net/wp-content/uploads/2017/09/Logo.png?fit=300%2C300&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></aside>				</div><!-- .footer-sidebar -->			
			</div><!-- .footer-widget-area -->

			
		</div><!-- .hm-container -->

		<div class="site-info">
			<div class="hm-container">
				<div class="site-info-owner">
					Copyright &#169; 2020 <a href="https://suunews.net/" title="SUU News" >SUU News</a>.				</div>			
				<div class="site-info-designer">
					Powered by <a></a> and <a href="https://themezhut.com/themes/hitmag/" target="_blank" title="HitMag WordPress Theme">HitMag</a>.				</div>
			</div><!-- .hm-container -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

	
</div><!-- #page -->


<!--  -->
        <div id="fb-root"></div>
        <script>(function(d, s, id) {
          var js, fjs = d.getElementsByTagName(s)[0];
          if (d.getElementById(id)) return;
          js = d.createElement(s); js.id = id;
          js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=&version=v2.3";
          fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));</script>	
    <!-- Your Google Analytics Plugin is missing the tracking ID -->
<link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/dist/vendor/wp-polyfill.min.js'></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://suunews.net/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://suunews.net/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://suunews.net/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://suunews.net/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://suunews.net/wp-content/plugins/full-site-editing/blog-posts-block/dist/view.js?ver=095557d67a4d672c72dd0372002def9d'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/suunews.net\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://suunews.net/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.7'></script>
<script type='text/javascript' src='https://suunews.net/wp-content/plugins/full-site-editing/event-countdown-block/blocks/event-countdown.js?ver=1576877996'></script>
<script type='text/javascript' src='https://suunews.net/wp-content/themes/hitmag/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='https://suunews.net/wp-content/themes/hitmag/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='https://suunews.net/wp-content/themes/hitmag/js/jquery.flexslider-min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://suunews.net/wp-content/themes/hitmag/js/scripts.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://suunews.net/wp-content/themes/hitmag/js/jquery.magnific-popup.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/suunews.net\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/thickbox/thickbox.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/spin.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/jquery.spin.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/suunews.net\/wp-admin\/admin-ajax.php","nonce":"c8934647d6","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"0","login_url":"https:\/\/suunews.net\/wp-login.php?redirect_to=https%3A%2F%2Fsuunews.net%2F2020%2F03%2F30%2Falbum-review-childish-gambinos-3-15-20%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/mediaelement/mediaelement-and-player.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/mediaelement/mediaelement-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/mediaelement/wp-mediaelement.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/mediaelement/renderers/vimeo.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var __CODENERIC_UAM_GLOBALS__ = {"ads":[],"ajax_url":"https:\/\/suunews.net\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://suunews.net/wp-content/plugins/ultimate-ads-manager/public/js/public.bundle.base-2.4.1.min.js?ver=1'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202014.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'135253056',post:'12891',tz:'-6',srv:'suunews.net'} ]);
	_stq.push([ 'clickTrackerInit', '135253056', '12891' ]);
</script>
</body>
</html>